Incident report

Power Outage in PO30 area - Fixed

Incident title
Power Outage in PO30 area
ID
7
Message

Due to a Southern Electric power outage. Customers connected to our Mast in this area may be without service while this is being worked on by SSE.

We will continue to monitor and update when power has been restored to that area. 

Status
Fixed
Opened at
08/07/2025 09:06
Affected services
Isle of Wight
Update entered at 09/07/2025 08:56

Power to the site has been restored. Customers service is now restored, if you are experiencing any further issues, please call us on 01983 770000.


Incident status changed to Fixed