- Incident title
-
Fixed Wireless Access - Partial Outage
- ID
-
6
- Message
-
Our Engineers are investigating an outage effecting some customers in the Cowes/Newport area and hope to resolve the issue as soon as possible.
- Status
-
Reported
- Opened at
-
28/06/2025 09:23
- Affected services
-
Isle of Wight
- Update entered at 28/06/2025 15:13
-
Update 15:00 - We have identified the issue and our engineers are working on getting full service restored.
We have managed to stabilise customers connected to this site. Some customer may experience some slow speeds or loss of service whilst we work on resolving this.
Service statuses set to Partial outage