Incident report

Partial Outage in Sandown/Brading Downs/Newchurch/Alverstorne Area - Fixed

Incident title
Partial Outage in Sandown/Brading Downs/Newchurch/Alverstorne Area
ID
5
Message

Due to a local power outage in the PO36 and surrounding areas. Some customer may be without service. SSE have stated they aim to have power restored by 13:30

Status
Fixed
Opened at
05/05/2025 12:30
Affected services
Isle of Wight
Update entered at 06/05/2025 13:21

Power has now been restored in the area


Incident status changed to Fixed

Update entered at 05/05/2025 13:21

SSE are on site and have updated their restore power time to 18:00


Service statuses set to Partial outage