Incident report

Power outage in west wight - Watching

Incident title
Power outage in west wight
ID
31
Message

There is currently a power outage in the west wight affecting our Tapnell and Porchfield masts, we are currently arranging backup power as SSEN have stated their estimated resoulution is 19:30.

Next update: 12:00.

Status
Watching
Opened at
11/08/2026 09:13
Affected services
Isle of Wight
Update entered at 11/08/2026 09:26

Before our engineers could attend, power appears to have been restored.

We are monitoring the situation closely.

Updates to come.


Incident status changed to Watching