Incident report

Network outage - Identified

Incident title
Network outage
ID
15
Message

We are experiencing a network outage. Updates to follow.

Status
Identified
Opened at
14/10/2025 15:45
Affected services
Telephone, Email, Hosted Phone System, Isle of Wight, Isle of Sheppy, On-net Services, OFNL, Openreach, On-net Services, Vodafone, Three, O2, EE, Cityfibre
Update entered at 15/10/2025 09:58

Update services


Service statuses set to Partial outage

Update entered at 15/10/2025 09:57

After a fairly quiet night we are again being hit by attackers which is blocking our services.

Our team are working hard to try and stop the attacks and also update customers.

We will continue to update you as we know more.

Update entered at 14/10/2025 21:47

For the last 24 hours, our core network has been subjected to multiple sustained denial of service attacked. We have worked hard to fend off the attacks, however, unfortunately at times this has become customer affecting. 

--
We have heard from several other independent ISP's that they too have been experiencing similar attacks. So, this malicious network traffic is not only aimed at Go internet. 

--

We're working with equipment vendors, suppliers, and some of the best brains in the industry to bring this issue to a resolution. 

Next update: 0900 15/10/2025

Update entered at 14/10/2025 16:20

We have identified the direction of the attack and are taking steps to mitigate it. Further updates to follow.


Incident status changed to Identified


Service statuses set to Degraded