- Incident title
-
Openreach service outage
- ID
-
1
- Message
-
We have identified an issue this morning with connections over the openreach network.
We are currently investigating this issue.
Next Update: 10:00
- Status
-
Fixed
- Opened at
-
23/04/2025 08:39
- Affected services
-
Openreach
- Update entered at 25/04/2025 06:53
-
This service has remained stable for 24 hours - we now consider this incident resolved.
Customers without service should seek support from our team on 01983770000.
Incident status changed to Fixed - Update entered at 24/04/2025 08:19
-
Things are looking stable this morning, any customers without connectivity should power down there equipment for a few moments - the restart will force the equipment to redial a connection.
After rebooting the router, if you are unable to connect please contact the team for assistance.
We will continue to monitor the service until 12:00 today before we consider this incident resolved.
Next Update: 12:00 24/04/2025
- Update entered at 23/04/2025 20:54
-
We now believe that most connections have restored. Some customers are still experiencing slower throughput and longer latency - however our supplier is carrying out emergency maintenance tonight between 00:01 and 06:00 to resolve this.
Next update: 08:30 24/04/2025
Incident status changed to Watching - Update entered at 23/04/2025 15:30
-
This incident is unfortunately ongoing with our supplier. The current advice from our supplier is to reboot your router often, in theory a space will become available for your router to connected.
We recognise this is far from idea and we are pushing for updates as often as we can.
Our supplier has planned maintenance at 00:01 tonight which they say will resolve the issue. Our own engineers will be monitoring the situation closely during this maintenance window.
We'll update this page at 01:00 24/04/2025.
- Update entered at 23/04/2025 15:20
-
This incident is ongoing, we can confirm that the issue is not within the Go Internet network and is within our upstream supplier network.
We have spoken with other independent service providers (we like to talk tech with each other) and now know that this issue is affecting lots of providers across the UK.
We’re pushing for an update on this matter and will update this service status as soon as we have a meaningful update from our supplier.
Service statuses set to Partial outage - Update entered at 23/04/2025 11:21
-
This incident is ongoing, we can confirm that the issue is not within the Go Internet network and is within our upstream supplier network.
We have spoken with other independent service providers (we like to talk tech with each other) and now know that this issue is affecting lots of providers across the UK.
We’re pushing for an update on this matter and will update this service status as soon as we have a meaningful update from our supplier.
Next update from us is the incident is not resolved before will be at 14:00
Service statuses set to Partial outage - Update entered at 23/04/2025 10:51
-
Engineers are still working with our supplier to resolve this issue.
Next update 12:00pm
Incident status changed to Identified - Update entered at 23/04/2025 08:50
-
Not all connections are affected. Investigation ongoing.
Incident status changed to Investigating